summaryrefslogtreecommitdiff
path: root/hw/kdrive/smi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/kdrive/smi/Makefile.am')
-rw-r--r--hw/kdrive/smi/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hw/kdrive/smi/Makefile.am b/hw/kdrive/smi/Makefile.am
index a6ac474b0..6cee31610 100644
--- a/hw/kdrive/smi/Makefile.am
+++ b/hw/kdrive/smi/Makefile.am
@@ -30,5 +30,9 @@ Xsmi_LDADD = \
@KDRIVE_LIBS@ \
@XSERVER_LIBS@
+Xsmi_DEPENDENCIES = \
+ libsmi.a \
+ @KDRIVE_LOCAL_LIBS@
+
relink:
rm -f $(bin_PROGRAMS) && make $(bin_PROGRAMS)