summaryrefslogtreecommitdiff
path: root/hw/xwayland/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xwayland/meson.build')
-rw-r--r--hw/xwayland/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/hw/xwayland/meson.build b/hw/xwayland/meson.build
index e24f39a75..b76d205b2 100644
--- a/hw/xwayland/meson.build
+++ b/hw/xwayland/meson.build
@@ -97,7 +97,10 @@ if build_glamor
srcs += 'xwayland-glx.c'
endif
if gbm_dep.found()
- srcs += 'xwayland-glamor-gbm.c'
+ srcs += [
+ 'xwayland-glamor-gbm.c',
+ 'xwayland-present.c'
+ ]
endif
if build_eglstream
eglstream_protodir = eglstream_dep.get_pkgconfig_variable('pkgdatadir')
@@ -111,7 +114,6 @@ if build_glamor
srcs += 'xwayland-glamor-eglstream.c'
endif
- srcs += 'xwayland-present.c'
if build_xv
srcs += 'xwayland-glamor-xv.c'
endif