summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-24 01:47:04 +0200
committerThomas Waldmann <tw AT waldmann-edv DOT de@localhost>2011-06-24 01:47:04 +0200
commitbdced3edbc8d062ba5f0318ff195dbd9af2f1990 (patch)
treeeef69e534b9141be393600543534bdd58a58ad0e /setup.py
parent79aa79bb292254c8c56354645ca00cbddc9b08da (diff)
downloadxstatic-git-bdced3edbc8d062ba5f0318ff195dbd9af2f1990.tar.gz
add some first versions of setup / code (untested)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..236e4ae
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+from setuptools import setup, find_packages
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
+
+setup(
+ name='XStatic',
+ version='0.0.1a0',
+ description='XStatic base package with minimal support code',
+ long_description=long_description,
+ classifiers=[],
+ keywords=[],
+ author='Thomas Waldmann',
+ author_email='tw@waldmann-edv.de',
+ license='MIT license',
+ packages=find_packages(),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[], # there should never be a dependency!
+)
+