summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJenkins <jenkins@review.openstack.org>2016-06-24 01:27:31 +0000
committerGerrit Code Review <review@openstack.org>2016-06-24 01:27:31 +0000
commit6a9182ab0001215cf5f0c41356f98c88202f48e7 (patch)
treeb2c342107f88acb396b73f8320d53315299ba5d4
parent8648295573aa0fd887a36684fde84c9c504a4b1e (diff)
parenteebdf56d4fe62c8aeb07d771f212d809a43e0598 (diff)
downloadxstatic-angular-bootstrap-6a9182ab0001215cf5f0c41356f98c88202f48e7.tar.gz
Merge "Update to use setuptools_scm for release version generation"0.11.0.4
-rw-r--r--.gitignore3
-rw-r--r--MANIFEST.in4
-rw-r--r--README.txt5
-rw-r--r--setup.cfg20
-rw-r--r--setup.py28
-rw-r--r--xstatic/pkg/angular_bootstrap/__init__.py2
6 files changed, 33 insertions, 29 deletions
diff --git a/.gitignore b/.gitignore
index b3085b8..a1af9cc 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,5 +5,6 @@
*.egg-info
.venv
.tox
-build
dist
+.eggs
+MANIFEST
diff --git a/MANIFEST.in b/MANIFEST.in
index dfee431..af3cdd3 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,8 +1,6 @@
include README.txt
-recursive-include xstatic/pkg/angular_bootstrap *
-
+recursive-include xstatic *
global-exclude *.pyc
global-exclude *.pyo
global-exclude *.orig
global-exclude *.rej
-
diff --git a/README.txt b/README.txt
index db5b55a..8f44db8 100644
--- a/README.txt
+++ b/README.txt
@@ -11,3 +11,8 @@ the XStatic base package, if you like.
You can find more info about the xstatic packaging way in the package `XStatic`.
+
+Maintenance
+-----------
+
+To release this package you must use the xstatic-release tool.
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..3473853
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,20 @@
+[metadata]
+name = XStatic-Angular-Bootstrap
+summary = Angular-Bootstrap 0.11.0 (XStatic packaging standard)
+description-file = README.rst
+maintainer = Maxime Vidori
+maintainer-email = maxime.vidori@enovance.com
+home-page = http://angular-ui.github.io/bootstrap/
+keywords = angular_bootstrap xstatic
+license = (same as Angular-Bootstrap)
+zip_safe = False
+namespace_packages =
+ xstatic
+ xstatic.pkg
+
+[files]
+packages =
+ xstatic
+
+[bdist_wheel]
+universal = True
diff --git a/setup.py b/setup.py
index 5458a9e..b680c15 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,7 @@
-from xstatic.pkg import angular_bootstrap as xs
-
-# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
-long_description = open('README.txt').read()
-
from setuptools import setup, find_packages
-
setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
- packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
- include_package_data=True,
- zip_safe=False,
- install_requires=[], # nothing! :)
- # if you like, you MAY use the 'XStatic' package.
+ name='XStatic-Angular-Bootstrap',
+ use_scm_version=True,
+ setup_requires=['setuptools_scm', 'wheel'],
+ packages=find_packages()
)
diff --git a/xstatic/pkg/angular_bootstrap/__init__.py b/xstatic/pkg/angular_bootstrap/__init__.py
index 5a6fe2c..b8b04e7 100644
--- a/xstatic/pkg/angular_bootstrap/__init__.py
+++ b/xstatic/pkg/angular_bootstrap/__init__.py
@@ -13,7 +13,7 @@ NAME = __name__.split('.')[-1] # package name (e.g. 'foo' or 'foo_bar')
VERSION = '0.11.0' # version of the packaged files, please use the upstream
# version number
-BUILD = '3' # our package build number, so we can release new builds
+BUILD = '4' # our package build number, so we can release new builds
# with fixes for xstatic stuff.
PACKAGE_VERSION = VERSION + '.' + BUILD # version used for PyPi