summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 13:23:28 +1000
committerRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 13:23:28 +1000
commitc9bbd6a3d1fac107a1adfb4a083a685ca5bccbbe (patch)
treea046cb1ff49242a77ecf7689081018ead287ee15
parent79165209e68cb81f6386f5ec0443c1002f6b658a (diff)
downloadxstatic-angular-bootstrap-c9bbd6a3d1fac107a1adfb4a083a685ca5bccbbe.tar.gz
Update with corrected xstatic-release
Change-Id: Ib72730b43676c54fe42c7cbb04d06644024903ab
-rw-r--r--setup.cfg6
-rw-r--r--setup.py22
2 files changed, 18 insertions, 10 deletions
diff --git a/setup.cfg b/setup.cfg
index 02241a5..288215c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,9 +1,9 @@
[metadata]
name = XStatic-Angular-Bootstrap
-description = Angular-Bootstrap 0.11.0 (XStatic packaging standard)
+description = Angular-Bootstrap 1.3.3 (XStatic packaging standard)
description-file = README.rst
-maintainer = Maxime Vidori
-maintainer-email = maxime.vidori@enovance.com
+maintainer = Rob Cresswell
+maintainer-email = robert.cresswell@outlook.com
home-page = http://angular-ui.github.io/bootstrap/
keywords = angular_bootstrap xstatic
license = MIT
diff --git a/setup.py b/setup.py
index 3bcb005..15984e9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,25 @@
from setuptools import setup, find_packages
+from xstatic.pkg import angular_bootstrap as xs
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
setup(
- name='XStatic-Angular-Bootstrap',
- description="""Angular-Bootstrap 0.11.0 (XStatic packaging standard)""",
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
long_description=long_description,
- maintainer="Maxime Vidori",
- maintainer_email='maxime.vidori@enovance.com',
- use_scm_version=True,
- setup_requires=['setuptools_scm', 'wheel'],
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
packages=find_packages(),
- include_package_data=True
+ namespace_packages=['xstatic', 'xstatic.pkg'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
)