summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Jones <r1chardj0n3s@gmail.com>2015-12-03 16:29:08 +1100
committerRichard Jones <r1chardj0n3s@gmail.com>2016-03-07 17:01:50 +1100
commiteebdf56d4fe62c8aeb07d771f212d809a43e0598 (patch)
tree18197d9bf55479a27320cfdb0882e88e8846b7a6 /setup.py
parentd799a1c60e2e27eb23d1cd7eb515bc3c0bc1e327 (diff)
downloadxstatic-angular-bootstrap-eebdf56d4fe62c8aeb07d771f212d809a43e0598.tar.gz
Update to use setuptools_scm for release version generation
To support openstack-infra we store the release version in git tags and use setuptools_scm to extract that tag in the setup file when generating sdist and wheel files. This patch includes the use of the new xstatic-release tool which handles the majority of management of metadata to support the infra release process. Change-Id: I14e0b5986d3433afd796ea44e66dfafd5003e732
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 4 insertions, 24 deletions
diff --git a/setup.py b/setup.py
index 5458a9e..b680c15 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,7 @@
-from xstatic.pkg import angular_bootstrap as xs
-
-# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
-long_description = open('README.txt').read()
-
from setuptools import setup, find_packages
-
setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
- packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
- include_package_data=True,
- zip_safe=False,
- install_requires=[], # nothing! :)
- # if you like, you MAY use the 'XStatic' package.
+ name='XStatic-Angular-Bootstrap',
+ use_scm_version=True,
+ setup_requires=['setuptools_scm', 'wheel'],
+ packages=find_packages()
)