summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThai Tran <tqtran@us.ibm.com>2015-01-14 17:43:59 -0800
committerThai Tran <tqtran@us.ibm.com>2015-01-14 17:43:59 -0800
commit322d85b797b9f97b1f2073d4e2f7a3dd1ec50bcc (patch)
treec3ee8faa97cab58a3b97ccf7f49809065adc3a92 /setup.py
downloadxstatic-angular-lrdragndrop-322d85b797b9f97b1f2073d4e2f7a3dd1ec50bcc.tar.gz
Initial commit.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d7ecd21
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+
+from xstatic.pkg import angular_smart_table as xs
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
+from setuptools import setup, find_packages
+
+setup(
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
+)