summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Jones <r1chardj0n3s@gmail.com>2016-09-06 16:32:33 +1000
committerRichard Jones <r1chardj0n3s@gmail.com>2016-09-06 18:50:50 +1000
commit3989e1f8e350c365c7bf1074ca9026b3a851b47f (patch)
tree5acebdc4058cd709a8e0d3e44b757dcb512b7252
parentf1e92703fc5f2e194ae2e287b2f6fff46d09c7ff (diff)
downloadxstatic-angular-smart-table-3989e1f8e350c365c7bf1074ca9026b3a851b47f.tar.gz
Update using xstatic-release 1.2.11.4.13.2
Change-Id: I72bad61b6db33fcd14e838301ebc139b543f3847
-rw-r--r--setup.py22
1 files changed, 15 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 873feaf..fc773cd 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,25 @@
from setuptools import setup, find_packages
+from xstatic.pkg import angular_smart_table as xs
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
setup(
- name='XStatic-smart-table',
- description="""smart-table 1.4.13 (XStatic packaging standard)""",
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
long_description=long_description,
- maintainer="Richard Jones",
- maintainer_email='r1chardj0n3s@gmail.com',
- use_scm_version=True,
- setup_requires=['setuptools_scm', 'wheel'],
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
packages=find_packages(),
- include_package_data=True
+ namespace_packages=['xstatic', 'xstatic.pkg'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
)