summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThai Tran <tqtran@us.ibm.com>2015-01-07 12:41:25 -0800
committerThai Tran <tqtran@us.ibm.com>2015-01-07 12:41:25 -0800
commite0fbf69fb156b995547471d71c5c6a7f88989d47 (patch)
tree4d4b0c1a1ba79332a215075ec61ce79e678f4967 /setup.py
downloadxstatic-angular-smart-table-e0fbf69fb156b995547471d71c5c6a7f88989d47.tar.gz
Adding Richard's zip files to this repo.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d7ecd21
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+
+from xstatic.pkg import angular_smart_table as xs
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
+from setuptools import setup, find_packages
+
+setup(
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
+)