summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py22
1 files changed, 15 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 873feaf..fc773cd 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,25 @@
from setuptools import setup, find_packages
+from xstatic.pkg import angular_smart_table as xs
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
setup(
- name='XStatic-smart-table',
- description="""smart-table 1.4.13 (XStatic packaging standard)""",
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
long_description=long_description,
- maintainer="Richard Jones",
- maintainer_email='r1chardj0n3s@gmail.com',
- use_scm_version=True,
- setup_requires=['setuptools_scm', 'wheel'],
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
packages=find_packages(),
- include_package_data=True
+ namespace_packages=['xstatic', 'xstatic.pkg'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
)