summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cresswell <robert.cresswell@outlook.com>2016-07-18 09:29:01 +0100
committerRob Cresswell <robert.cresswell@outlook.com>2016-07-19 08:17:20 +0100
commit5a30bee80d67c0f26ecbf05726f4838dbae3f276 (patch)
treec014982322454fd386d38226b01dccd4d64533f5
parentd0dd552b6026a5c153180a68b217830425c7d352 (diff)
downloadxstatic-angular-5a30bee80d67c0f26ecbf05726f4838dbae3f276.tar.gz
Update with xstatic-release script1.4.10.1
Change-Id: I85514e4afde528e72d8b2a44a79702427df449f3
-rw-r--r--.gitignore2
-rw-r--r--MANIFEST.in8
-rw-r--r--setup.cfg20
-rw-r--r--setup.py30
-rw-r--r--xstatic/pkg/angular/__init__.py4
5 files changed, 34 insertions, 30 deletions
diff --git a/.gitignore b/.gitignore
index b3085b8..31c8ca6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,6 +3,8 @@
*.sqlite3
.DS_STORE
*.egg-info
+.eggs
+MANIFEST
.venv
.tox
build
diff --git a/MANIFEST.in b/MANIFEST.in
deleted file mode 100644
index ae010ce..0000000
--- a/MANIFEST.in
+++ /dev/null
@@ -1,8 +0,0 @@
-include README.txt
-recursive-include xstatic/pkg/angular *
-
-global-exclude *.pyc
-global-exclude *.pyo
-global-exclude *.orig
-global-exclude *.rej
-
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..1ae9ddf
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,20 @@
+[metadata]
+name = XStatic-Angular
+summary = Angular 1.4.10 (XStatic packaging standard)
+description-file = README.rst
+maintainer = Rob Cresswell
+maintainer-email = robert.cresswell@outlook.com
+home-page = http://angularjs.org
+keywords = angular xstatic
+license = MIT
+zip_safe = False
+namespace_packages =
+ xstatic
+ xstatic.pkg
+
+[files]
+packages =
+ xstatic
+
+[bdist_wheel]
+universal = True
diff --git a/setup.py b/setup.py
index b2774f3..4fb31b4 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,17 @@
-from xstatic.pkg import angular as xs
+from setuptools import setup, find_packages
# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
+# it to generate your project's PyPI page.
long_description = open('README.txt').read()
-from setuptools import setup, find_packages
-
setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
+ name='XStatic-Angular',
+ summary="""Angular 1.4.10 (XStatic packaging standard)""",
+ description=long_description,
+ maintainer="Rob Cresswell",
+ maintainer_email='robert.cresswell@outlook.com',
+ use_scm_version=True,
+ setup_requires=['setuptools_scm', 'wheel'],
packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
- include_package_data=True,
- zip_safe=False,
- install_requires=[], # nothing! :)
- # if you like, you MAY use the 'XStatic' package.
+ include_package_data=True
)
diff --git a/xstatic/pkg/angular/__init__.py b/xstatic/pkg/angular/__init__.py
index 17ba089..88b1526 100644
--- a/xstatic/pkg/angular/__init__.py
+++ b/xstatic/pkg/angular/__init__.py
@@ -24,8 +24,8 @@ CLASSIFIERS = []
KEYWORDS = '%s xstatic' % NAME
# XStatic-* package maintainer:
-MAINTAINER = 'Radomir Dopieralski'
-MAINTAINER_EMAIL = 'openstack@sheep.art.pl'
+MAINTAINER = 'Rob Cresswell'
+MAINTAINER_EMAIL = 'robert.cresswell@outlook.com'
# this refers to the project homepage of the stuff we packaged:
HOMEPAGE = 'http://angularjs.org'