summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 13:21:36 +1000
committerRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 13:21:36 +1000
commit8d809659b75b616461877807c937cb5fa2173b31 (patch)
tree3007c2f13088635afdca7029ea4f914000e7c586
parent55b99c03abd5f6b1556ab46d2e592405c5a89e2c (diff)
downloadxstatic-angular-8d809659b75b616461877807c937cb5fa2173b31.tar.gz
Update with corrected xstatic-release1.5.8.0
Change-Id: I57b7d6c3d98d41f253b15b9d1030b04f4e9e7734
-rw-r--r--setup.py22
1 files changed, 15 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index e2a9945..2e0cf4c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,25 @@
from setuptools import setup, find_packages
+from xstatic.pkg import angular as xs
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
setup(
- name='XStatic-Angular',
- description="""Angular 1.5.8 (XStatic packaging standard)""",
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
long_description=long_description,
- maintainer="Rob Cresswell",
- maintainer_email='robert.cresswell@outlook.com',
- use_scm_version=True,
- setup_requires=['setuptools_scm', 'wheel'],
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
packages=find_packages(),
- include_package_data=True
+ namespace_packages=['xstatic', 'xstatic.pkg'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
)