summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py22
1 files changed, 15 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index e2a9945..2e0cf4c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,25 @@
from setuptools import setup, find_packages
+from xstatic.pkg import angular as xs
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
setup(
- name='XStatic-Angular',
- description="""Angular 1.5.8 (XStatic packaging standard)""",
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
long_description=long_description,
- maintainer="Rob Cresswell",
- maintainer_email='robert.cresswell@outlook.com',
- use_scm_version=True,
- setup_requires=['setuptools_scm', 'wheel'],
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
packages=find_packages(),
- include_package_data=True
+ namespace_packages=['xstatic', 'xstatic.pkg'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
)