summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 13:27:12 +1000
committerRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 13:27:36 +1000
commit4ca4a059f89287b40441566a4a6bf32785295504 (patch)
tree4ea28885e1326851b3ad71df5b570595515a1e28
parent577f0ce201e48aaf2d5fbf4d9799013eb108ffd3 (diff)
downloadxstatic-bootstrap-scss-4ca4a059f89287b40441566a4a6bf32785295504.tar.gz
Update with corrected xstatic-release3.3.7.1
Change-Id: Ib60d7cd76f00d7959c703063b008273759edf5b3
-rw-r--r--setup.cfg2
-rw-r--r--setup.py24
-rw-r--r--xstatic/pkg/bootstrap_scss/__init__.py2
3 files changed, 18 insertions, 10 deletions
diff --git a/setup.cfg b/setup.cfg
index 916bcc6..36a3fc4 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = XStatic-Bootstrap-SCSS
-summary = Bootstrap-SCSS 3.3.7 (XStatic packaging standard)
+description = Bootstrap-SCSS 3.3.7 (XStatic packaging standard)
description-file = README.rst
maintainer = Radomir Dopieralski
maintainer-email = openstack@sheep.art.pl
diff --git a/setup.py b/setup.py
index 8f0440a..aed0424 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,25 @@
from setuptools import setup, find_packages
+from xstatic.pkg import bootstrap_scss as xs
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
long_description = open('README.txt').read()
setup(
- name='XStatic-Bootstrap-SCSS',
- summary="""Bootstrap-SCSS 3.3.7 (XStatic packaging standard)""",
- description=long_description,
- maintainer="Radomir Dopieralski",
- maintainer_email='openstack@sheep.art.pl',
- use_scm_version=True,
- setup_requires=['setuptools_scm', 'wheel'],
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
packages=find_packages(),
- include_package_data=True
+ namespace_packages=['xstatic', 'xstatic.pkg'],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
)
diff --git a/xstatic/pkg/bootstrap_scss/__init__.py b/xstatic/pkg/bootstrap_scss/__init__.py
index a66c79a..e6fd0de 100644
--- a/xstatic/pkg/bootstrap_scss/__init__.py
+++ b/xstatic/pkg/bootstrap_scss/__init__.py
@@ -13,7 +13,7 @@ NAME = __name__.split('.')[-1] # package name (e.g. 'foo' or 'foo_bar')
VERSION = '3.3.7' # version of the packaged files, please use the upstream
# version number
-BUILD = '0' # our package build number, so we can release new builds
+BUILD = '1' # our package build number, so we can release new builds
# with fixes for xstatic stuff.
PACKAGE_VERSION = VERSION + '.' + BUILD # version used for PyPi