summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cresswell <robert.cresswell@outlook.com>2016-08-23 14:42:52 +0100
committerRichard Jones <r1chardj0n3s@gmail.com>2016-09-07 11:49:32 +1000
commitd2c33c15a81574c5380c1825aaa4b2a2c584bd4f (patch)
treedb6e461aa2513fc9c0ef0c832077103a2755b34c
parent4ed82aa2249dc3d4cd28b53351972ea59b3a0c0e (diff)
downloadxstatic-d3-d2c33c15a81574c5380c1825aaa4b2a2c584bd4f.tar.gz
Update with xstatic-release script3.5.17.0
Change-Id: Ice27b8192e3b2b59d4845ab5732410a2855edb94
-rw-r--r--MANIFEST.in4
-rw-r--r--setup.cfg20
-rw-r--r--setup.py10
3 files changed, 25 insertions, 9 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 793f719..af3cdd3 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,8 +1,6 @@
include README.txt
-recursive-include xstatic/pkg/d3 *
-
+recursive-include xstatic *
global-exclude *.pyc
global-exclude *.pyo
global-exclude *.orig
global-exclude *.rej
-
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..a0b171a
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,20 @@
+[metadata]
+name = XStatic-D3
+description = D3 3.5.17 (XStatic packaging standard)
+description-file = README.rst
+maintainer = Radomir Dopieralski
+maintainer-email = openstack@sheep.art.pl
+home-page = http://d3js.org/
+keywords = d3 xstatic
+license = BSD
+zip_safe = False
+namespace_packages =
+ xstatic
+ xstatic.pkg
+
+[files]
+packages =
+ xstatic
+
+[bdist_wheel]
+universal = True
diff --git a/setup.py b/setup.py
index ea55db4..6b94948 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,10 @@
+from setuptools import setup, find_packages
from xstatic.pkg import d3 as xs
# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
+# it to generate your project's PyPI page.
long_description = open('README.txt').read()
-from setuptools import setup, find_packages
-
setup(
name=xs.PACKAGE_NAME,
version=xs.PACKAGE_VERSION,
@@ -19,9 +18,8 @@ setup(
url=xs.HOMEPAGE,
platforms=xs.PLATFORMS,
packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
+ namespace_packages=['xstatic', 'xstatic.pkg'],
include_package_data=True,
zip_safe=False,
- install_requires=[], # nothing! :)
- # if you like, you MAY use the 'XStatic' package.
+ install_requires=[],
)