summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormanchandavishal <manchandavishal143@gmail.com>2023-01-30 15:32:39 +0530
committermanchandavishal <manchandavishal143@gmail.com>2023-02-15 21:41:34 +0530
commit8c02750f5bb02ab67b25cacd029155a9c2d460c6 (patch)
treeeba0432c66f42e7de86eb5ceca4eafd2aa9c2931 /setup.py
parent2c3fadc34faa4ddd7ea782152dd3eafd3010ebf7 (diff)
downloadxstatic-font-awesome-8c02750f5bb02ab67b25cacd029155a9c2d460c6.tar.gz
Step 2: Remove Project Content- Retire xstatic-font-awesome
As discussed in the horizon weekly meeting[1] and announced on open-discuss ML [2], Horizon team decided to retire xstatic-font-awesome project from the OpenStack umbrella and contributors from MoinMoin going to maintain this project under python-xstatic[3]. This patch is step 2 as mentioned in retiring a project guide[4]. [1] https://meetings.opendev.org/irclogs/%23openstack-horizon/%23openstack-horizon.2023-01-18.log.html#t2023-01-18T15:05:56 [2] https://lists.openstack.org/pipermail/openstack-discuss/2023-January/031884.html [3] https://github.com/xstatic-py/xstatic-font-awesome [4] https://docs.opendev.org/opendev/infra-manual/latest/drivers.html#step-2-remove-project-content Depends-On: https://review.opendev.org/c/openstack/project-config/+/871703 Change-Id: I6c3d5505f3fe803649e16d182f032d6afe9840d4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 0 insertions, 25 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index dd0f734..0000000
--- a/setup.py
+++ /dev/null
@@ -1,25 +0,0 @@
-from setuptools import setup, find_packages
-from xstatic.pkg import font_awesome as xs
-
-# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
-long_description = open('README.txt').read()
-
-setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
- packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg'],
- include_package_data=True,
- zip_safe=False,
- install_requires=[],
-)