summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwoomatt <matt.wood@hp.com>2015-07-21 16:11:56 -0600
committerwoomatt <matt.wood@hp.com>2015-07-22 09:21:07 -0600
commitb309c06b51b039d90340212fc181d56c736183bb (patch)
tree65dea89b4baadbfb1b34b601c9833c02de83bdb6
parentcf95a6556c18762df48a3c66c28ccf0fea14c049 (diff)
downloadxstatic-jasmine-b309c06b51b039d90340212fc181d56c736183bb.tar.gz
Make PBR work2.2.0.post32.2.0.2
Currently, this xstatic library isn't updating automagically because PBR requires a setup.cfg file, and a different setup.py file. Change-Id: Idec29a425bebba3fcabded25908835e12fc53624
-rw-r--r--.gitignore3
-rw-r--r--setup.cfg17
-rw-r--r--setup.py49
3 files changed, 45 insertions, 24 deletions
diff --git a/.gitignore b/.gitignore
index b3085b8..236a765 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,7 +3,10 @@
*.sqlite3
.DS_STORE
*.egg-info
+.eggs
.venv
.tox
build
dist
+AUTHORS
+ChangeLog
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..10d2a0e
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,17 @@
+# This config file has been created by
+# <horizon home>/tools/make_xstatic_setup_cfg.py
+
+[metadata]
+name = XStatic-Jasmine
+summary = Jasmine 2.2.0 (XStatic packaging standard)
+description-file = README.txt
+author = Radomir Dopieralski
+author-email = openstack@sheep.art.pl
+home-page = http://jasmine.github.io/
+
+[files]
+packages = xstatic
+namespace_packages =
+ xstatic
+ xstatic.pkg
+
diff --git a/setup.py b/setup.py
index dbc4694..18d2f42 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,28 @@
-from xstatic.pkg import jasmine as xs
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
-# The README.txt file should be written in reST so that PyPI can use
-# it to generate your project's PyPI page.
-long_description = open('README.txt').read()
+import setuptools
-from setuptools import setup, find_packages
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
-setup(
- name=xs.PACKAGE_NAME,
- version=xs.PACKAGE_VERSION,
- description=xs.DESCRIPTION,
- long_description=long_description,
- classifiers=xs.CLASSIFIERS,
- keywords=xs.KEYWORDS,
- maintainer=xs.MAINTAINER,
- maintainer_email=xs.MAINTAINER_EMAIL,
- license=xs.LICENSE,
- url=xs.HOMEPAGE,
- platforms=xs.PLATFORMS,
- packages=find_packages(),
- namespace_packages=['xstatic', 'xstatic.pkg', ],
- include_package_data=True,
- zip_safe=False,
- install_requires=[], # nothing! :)
- # if you like, you MAY use the 'XStatic' package.
-)
+setuptools.setup(
+ setup_requires=['pbr>=1.3'],
+ pbr=True)