summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw AT waldmann-edv DOT de>2011-06-26 07:38:20 +0200
committerThomas Waldmann <tw AT waldmann-edv DOT de>2011-06-26 07:38:20 +0200
commit429e413364912b56357ddb489b8863fa56ae08e2 (patch)
tree43a627566e4dcf4c46840c5818cd46134875e88f /setup.py
downloadxstatic-jquery-429e413364912b56357ddb489b8863fa56ae08e2.tar.gz
xstatic-jquery package, initial commit
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..746d00a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from setuptools import setup, find_packages
+
+from xstatic.pkg.jquery import JQuery as xs
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
+
+setup( # better now, though not all of these make sense outside of setup.py
+ name='XStatic-' + xs.display_name,
+ version=xs.version,
+ description=xs.description,
+ long_description=long_description,
+ classifiers=xs.classifiers, # for pypi
+ keywords=xs.keywords, # for pypi
+ author=xs.author,
+ author_email=xs.author_email,
+ license=xs.license,
+ url=xs.homepage,
+ platforms=xs.platforms,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=['XStatic'], # this is just a MINIMAL support code package
+)