summaryrefslogtreecommitdiff
path: root/xstatic/pkg/jquery/__init__.py
diff options
context:
space:
mode:
Diffstat (limited to 'xstatic/pkg/jquery/__init__.py')
-rw-r--r--xstatic/pkg/jquery/__init__.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/xstatic/pkg/jquery/__init__.py b/xstatic/pkg/jquery/__init__.py
index fa393e7..44b2821 100644
--- a/xstatic/pkg/jquery/__init__.py
+++ b/xstatic/pkg/jquery/__init__.py
@@ -4,7 +4,14 @@ jQuery package
from os.path import join, dirname
-from xstatic.main import XStatic
+try:
+ from xstatic.main import XStatic
+except ImportError:
+ class XStatic(object):
+ """
+ just a dummy for the time when setup.py is running and
+ for the case that xstatic is not already installed.
+ """
class JQuery(XStatic):
name = 'jquery' # short, all lowercase name