summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRandy Bertram <rbertram@us.ibm.com>2015-02-18 08:29:16 -0500
committerRandy Bertram <rbertram@us.ibm.com>2015-02-20 09:50:47 -0500
commit1e15e5bbb55b838bc4289ebc5c39d9c4dd9cb1e4 (patch)
tree5084c8f6a6fdd76c4ebc8345389b3849972e39e8 /setup.py
parentc5a716cb22ca9b4ef75a91ac6bd43fa582a42f69 (diff)
downloadxstatic-magic-search-1e15e5bbb55b838bc4289ebc5c39d9c4dd9cb1e4.tar.gz
Initializing with MagicSearch 0.1.5.9
First commit of MagicSearch code Change-Id: Idc51127a72a0a80aab706690db26387cc9f72b81
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..b8765cd
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from xstatic.pkg import magic_search as xs
+
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
+
+from setuptools import setup, find_packages
+
+setup(
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[], # nothing! :)
+ # if you like, you MAY use the 'XStatic' package.
+)