summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8633c85..4c7d7d6 100644
--- a/setup.py
+++ b/setup.py
@@ -7,9 +7,13 @@ XStatic - setup.py
Works with: setuptools
"""
+import os.path
# The README.txt file should be written in reST so that PyPI can use
# it to generate your project's PyPI page.
-long_description = open('README.txt').read()
+readme_path = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+ 'README.txt')
+with open(readme_path) as f:
+ long_description = f.read()
from setuptools import setup, find_packages