summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2022-12-29 00:25:18 +0800
committerJia Tan <jiat0218@gmail.com>2023-01-02 22:20:04 +0800
commit3959162baec074511d83ba0fec1284c3ed724799 (patch)
tree5360ec5c8c7bb7a7474064cbd0077ec9600e83d3 /CMakeLists.txt
parentf16e12d5e755d371247202fcccbcccd1ec16b2cf (diff)
downloadxz-3959162baec074511d83ba0fec1284c3ed724799.tar.gz
Tests: Creates test_index_hash.c
Tests all API functions exported from index_hash.h. Does not have a dedicated test for lzma_index_hash_end.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4f1059..3a58d74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -801,6 +801,7 @@ if(BUILD_TESTING)
test_filter_flags
test_hardware
test_index
+ test_index_hash
test_memlimit
test_stream_flags
test_vli
@@ -812,6 +813,7 @@ if(BUILD_TESTING)
target_include_directories("${TEST}" PRIVATE
src/common
src/liblzma/api
+ src/liblzma
lib
)