summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-01-10 08:29:32 +0200
committerLasse Collin <lasse.collin@tukaani.org>2023-01-10 08:29:32 +0200
commit5e34774c31d1b7509b5cb77a3be9973adec59ea0 (patch)
tree7b3bc5940b98ab07534647bd37efba0156d6261a /CMakeLists.txt
parent6e652ceb18c615c578c869db300fa0756788b4e0 (diff)
downloadxz-5e34774c31d1b7509b5cb77a3be9973adec59ea0.tar.gz
CMake: Fix appending to CMAKE_RC_FLAGS.
It's a string, not a list. It only worked when the variable was empty. Thanks to Iouri Kharon.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3d5fc7..e5b4e5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,7 +97,7 @@ if(WIN32 AND CMAKE_C_COMPILER_ID STREQUAL "GNU")
# Use workarounds with GNU windres. The \x20 in PACKAGE_NAME works
# with gcc too so we don't need to worry how to pass different flags
# to windres and gcc.
- list(APPEND CMAKE_RC_FLAGS "--use-temp-file")
+ string(APPEND CMAKE_RC_FLAGS " --use-temp-file")
set(PACKAGE_NAME "XZ\\x20Utils")
else()
# Elsewhere a space is safe. This also keeps things compatible with