summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2022-11-09 14:45:05 +0200
committerLasse Collin <lasse.collin@tukaani.org>2022-11-09 14:45:05 +0200
commit781da8d6c44de6aa278c916375250668a0b107f2 (patch)
tree1597fe4f0b889e7bbf5e82e94aa67922d499481f /CMakeLists.txt
parentdf8ad4af65a9c4846b108550d0083770a69dee64 (diff)
downloadxz-781da8d6c44de6aa278c916375250668a0b107f2.tar.gz
CMake: Add lzip decoder files and #define to the build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd09d48..e3af3bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +110,7 @@ add_compile_definitions(
HAVE_MF_BT4
HAVE_MF_HC3
HAVE_MF_HC4
+ HAVE_LZIP_DECODER
# Standard headers and types are available:
HAVE_STDBOOL_H
@@ -280,6 +281,8 @@ add_library(liblzma
src/liblzma/common/index_encoder.c
src/liblzma/common/index_encoder.h
src/liblzma/common/index_hash.c
+ src/liblzma/common/lzip_decoder.c
+ src/liblzma/common/lzip_decoder.h
src/liblzma/common/memcmplen.h
src/liblzma/common/outqueue.c
src/liblzma/common/outqueue.h