summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2022-09-19 19:34:56 +0300
committerLasse Collin <lasse.collin@tukaani.org>2022-09-19 20:23:46 +0300
commitecb966de308c255bb4735a7307ef9901c643a9de (patch)
tree2f590bc34e34fdc8388cbe106fff4d281d88f409 /CMakeLists.txt
parent177bdc922cb17bd0fd831ab8139dfae912a5c2b8 (diff)
downloadxz-ecb966de308c255bb4735a7307ef9901c643a9de.tar.gz
liblzma: Add experimental ARM64 BCJ filter with a temporary Filter ID.
That is, the Filter ID will be changed once the design is final. The current version will be removed. So files created with the tempoary Filter ID won't be supported in the future.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c82f0a..bd09d48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,6 +86,7 @@ add_compile_definitions(
HAVE_DECODERS
HAVE_DECODER_ARM
HAVE_DECODER_ARMTHUMB
+ HAVE_DECODER_ARM64
HAVE_DECODER_DELTA
HAVE_DECODER_IA64
HAVE_DECODER_LZMA1
@@ -96,6 +97,7 @@ add_compile_definitions(
HAVE_ENCODERS
HAVE_ENCODER_ARM
HAVE_ENCODER_ARMTHUMB
+ HAVE_ENCODER_ARM64
HAVE_ENCODER_DELTA
HAVE_ENCODER_IA64
HAVE_ENCODER_LZMA1
@@ -331,6 +333,7 @@ add_library(liblzma
src/liblzma/rangecoder/range_encoder.h
src/liblzma/simple/arm.c
src/liblzma/simple/armthumb.c
+ src/liblzma/simple/arm64.c
src/liblzma/simple/ia64.c
src/liblzma/simple/powerpc.c
src/liblzma/simple/simple_coder.c