summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2023-03-17 01:30:36 +0800
committerJia Tan <jiat0218@gmail.com>2023-03-17 01:42:28 +0800
commit509157c80c500426ec853bd992d684ebafc8500c (patch)
tree37d3f95015a9b8a45780558646d2a7b239038a53 /Makefile.am
parentfd90e2f4c29180b44e33c7ef726f94e4eae54ed3 (diff)
downloadxz-509157c80c500426ec853bd992d684ebafc8500c.tar.gz
Doc: Rename Doxygen HTML doc directory name liblzma => api.
When the docs are installed, calling the directory "liblzma" is confusing since multiple other files in the doc directory are for liblzma. This should also make it more natural for distros when they package the documentation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d52e0f..f562f90 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,15 +47,15 @@ dist_examplesold_DATA = \
# Install the Doxygen generated documentation if they were built.
install-data-local:
- if test -d "$(srcdir)/doc/liblzma" ; then \
- $(MKDIR_P) "$(DESTDIR)$(docdir)/liblzma" && \
- $(INSTALL_DATA) "$(srcdir)"/doc/liblzma/* \
- "$(DESTDIR)$(docdir)/liblzma"; \
+ if test -d "$(srcdir)/doc/api" ; then \
+ $(MKDIR_P) "$(DESTDIR)$(docdir)/api" && \
+ $(INSTALL_DATA) "$(srcdir)"/doc/api/* \
+ "$(DESTDIR)$(docdir)/api"; \
fi
# Remove the Doxygen generated documentation when uninstalling.
uninstall-local:
- rm -rf "$(DESTDIR)$(docdir)/liblzma"
+ rm -rf "$(DESTDIR)$(docdir)/api"
endif
EXTRA_DIST = \
@@ -112,10 +112,10 @@ dist-hook:
> "$$dest/txt/$$BASE.txt"; \
done; \
fi
- if test -d "$(srcdir)/doc/liblzma" ; then \
- $(MKDIR_P) "$(distdir)/doc/liblzma" && \
- $(INSTALL_DATA) "$(srcdir)"/doc/liblzma/* \
- "$(distdir)/doc/liblzma"; \
+ if test -d "$(srcdir)/doc/api" ; then \
+ $(MKDIR_P) "$(distdir)/doc/api" && \
+ $(INSTALL_DATA) "$(srcdir)"/doc/api/* \
+ "$(distdir)/doc/api"; \
fi
# This works with GNU tar and gives cleaner package than normal 'make dist'.