summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2010-10-23 17:25:52 +0300
committerLasse Collin <lasse.collin@tukaani.org>2010-10-23 17:25:52 +0300
commite45929260cd902036efd40c5610a8d0a50d5712b (patch)
tree1d1a4af40ecb2e9e5a86437c943615d1218698b7 /Makefile.am
parent6e1326fcdf6b6209949be57cfe3ad4b781b65168 (diff)
downloadxz-e45929260cd902036efd40c5610a8d0a50d5712b.tar.gz
Build: Fix mydist rule when .git doesn't exist.v5.0.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 809197e..91c7c08 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,7 @@ dist-hook:
# This works with GNU tar and gives cleaner package than normal 'make dist'.
mydist:
+ VERSION=$(VERSION); \
if test -d "$(srcdir)/.git" && type git > /dev/null 2>&1; then \
SNAPSHOT=`cd "$(srcdir)" && git describe --abbrev=4 | cut -b2-`; \
test -n "$$SNAPSHOT" && VERSION=$$SNAPSHOT; \