summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2016-06-30 20:27:36 +0300
committerLasse Collin <lasse.collin@tukaani.org>2016-06-30 20:27:36 +0300
commit446e4318fa79788e09299d5953b5dd428953d14b (patch)
tree23fe6d61a55d263620137cbe36b6b9e60f6646ab /configure.ac
parent1b0ac0c53c761263e91e34195cb21dfdcfeac0bd (diff)
downloadxz-446e4318fa79788e09299d5953b5dd428953d14b.tar.gz
xz: Fix copying of timestamps on Windows.
xz used to call utime() on Windows, but its result gets lost on close(). Using _futime() seems to work. Thanks to Martok for reporting the bug: http://www.mail-archive.com/xz-devel@tukaani.org/msg00261.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3df4348..81abce5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -672,7 +672,7 @@ AC_C_BIGENDIAN
gl_GETOPT
# Find the best function to set timestamps.
-AC_CHECK_FUNCS([futimens futimes futimesat utimes utime], [break])
+AC_CHECK_FUNCS([futimens futimes futimesat utimes _futime utime], [break])
# This is nice to have but not mandatory.
AC_CHECK_FUNCS([posix_fadvise])