summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2015-11-03 20:35:19 +0200
committerLasse Collin <lasse.collin@tukaani.org>2015-11-03 20:35:19 +0200
commit5cbca1205deeb6fb7afe7a864fa68a57466d928a (patch)
tree50131024a9ae5f21afa8ec85408c3484221d0bbd /configure.ac
parentaf13781886c8e7a0aabebb5141ea282dc364f5c6 (diff)
downloadxz-5cbca1205deeb6fb7afe7a864fa68a57466d928a.tar.gz
Build: Simplify $enable_{encoders,decoders} usage a bit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cb6eac9..53cb630 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,6 +97,7 @@ AC_ARG_ENABLE([encoders], AS_HELP_STRING([--enable-encoders=LIST],
[], [enable_encoders=SUPPORTED_FILTERS])
enable_encoders=`echo "$enable_encoders" | sed 's/,/ /g'`
if test "x$enable_encoders" = xno || test "x$enable_encoders" = x; then
+ enable_encoders=no
AC_MSG_RESULT([(none)])
else
for arg in $enable_encoders
@@ -126,6 +127,7 @@ AC_ARG_ENABLE([decoders], AS_HELP_STRING([--enable-decoders=LIST],
[], [enable_decoders=SUPPORTED_FILTERS])
enable_decoders=`echo "$enable_decoders" | sed 's/,/ /g'`
if test "x$enable_decoders" = xno || test "x$enable_decoders" = x; then
+ enable_decoders=no
AC_MSG_RESULT([(none)])
else
for arg in $enable_decoders
@@ -153,8 +155,8 @@ if test "x$enable_encoder_lzma2$enable_encoder_lzma1" = xyesno \
AC_MSG_ERROR([LZMA2 requires that LZMA1 is also enabled.])
fi
-AM_CONDITIONAL(COND_MAIN_ENCODER, test "x$enable_encoders" != xno && test "x$enable_encoders" != x)
-AM_CONDITIONAL(COND_MAIN_DECODER, test "x$enable_decoders" != xno && test "x$enable_decoders" != x)
+AM_CONDITIONAL(COND_MAIN_ENCODER, test "x$enable_encoders" != xno)
+AM_CONDITIONAL(COND_MAIN_DECODER, test "x$enable_decoders" != xno)
m4_foreach([NAME], [SUPPORTED_FILTERS],
[AM_CONDITIONAL(COND_FILTER_[]m4_toupper(NAME), test "x$enable_filter_[]NAME" = xyes)