summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2022-11-14 17:58:07 +0200
committerLasse Collin <lasse.collin@tukaani.org>2022-11-14 17:58:07 +0200
commitac10b1b3622e70881595586edfb8a3ebdcd76bb6 (patch)
tree4e078d6eaecc7c6b1b844a81a4bc19ae6b960d41 /configure.ac
parenteb0f1450ad9f23dac03050d9c8375980240aee21 (diff)
downloadxz-ac10b1b3622e70881595586edfb8a3ebdcd76bb6.tar.gz
Build: Omit x86_64 from --enable-assembler.
It didn't do anything. There are only 32-bit x86 assembly files and it feels likely that new files won't be added as intrinsics in C are more portable across toolchains and OSes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index cf226b2..ddc82a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -354,22 +354,20 @@ if test "x$enable_assembler" = xyes; then
linux* | *bsd* | mingw* | cygwin | msys | *djgpp*)
case $host_cpu in
i?86) enable_assembler=x86 ;;
- x86_64) enable_assembler=x86_64 ;;
esac
;;
esac
fi
case $enable_assembler in
- x86 | x86_64 | no)
+ x86 | no)
AC_MSG_RESULT([$enable_assembler])
;;
*)
AC_MSG_RESULT([])
- AC_MSG_ERROR([--enable-assembler accepts only `yes', `no', `x86', or `x86_64'.])
+ AC_MSG_ERROR([--enable-assembler accepts only `yes', `no', or `x86' (32-bit).])
;;
esac
AM_CONDITIONAL(COND_ASM_X86, test "x$enable_assembler" = xx86)
-AM_CONDITIONAL(COND_ASM_X86_64, test "x$enable_assembler" = xx86_64)
#####################