summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2007-12-10 15:02:50 +0200
committerLasse Collin <lasse.collin@tukaani.org>2007-12-10 15:02:50 +0200
commitb499a0403ea5c41d6a25b40275eb6c57643052ce (patch)
tree8c2aba85036f3ea8ef3bd3c2faa66cdaf76203dc /configure.ac
parent2ab8adb5165a0b77114a7eb21f9ff1e6a266f172 (diff)
downloadxz-b499a0403ea5c41d6a25b40275eb6c57643052ce.tar.gz
Disabled some unneeded warnings and made "make dist" work.v4.42.2alpha
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3f9ad53..c0400a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -542,13 +542,16 @@ if test -n "$GCC" ; then
# * -Wcast-align breaks optimized CRC32 and CRC64 implementation
# on some architectures (not on x86), where this warning is bogus,
# because we take care of correct alignment.
+ # * -Winline, -Wdisabled-optimization, -Wunsafe-loop-optimizations
+ # don't seem so useful here; at least the last one gives some
+ # warnings which are not bugs.
for NEW_FLAG in -Wextra -Wformat=2 -Winit-self -Wstrict-aliasing=2 \
- -Wfloat-equal -Wshadow -Wunsafe-loop-optimizations \
- -Wpointer-arith -Wbad-function-cast -Wwrite-strings \
+ -Wfloat-equal -Wshadow -Wpointer-arith \
+ -Wbad-function-cast -Wwrite-strings \
-Waggregate-return -Wstrict-prototypes \
-Wold-style-definition -Wmissing-prototypes \
-Wmissing-declarations -Wmissing-noreturn \
- -Wredundant-decls -Winline -Wdisabled-optimization
+ -Wredundant-decls
do
AC_MSG_CHECKING([if $CC accepts $NEW_FLAG])
OLD_CFLAGS="$CFLAGS"