summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-03-16 21:23:48 +0800
committerJia Tan <jiat0218@gmail.com>2023-03-17 01:42:28 +0800
commitc97d12f300b2a94c9f54a44c8931c8bc08cf0a73 (patch)
tree5b537fb10b1c59951bae7c4df90a05153a4a53ed /configure.ac
parent1b7661faa4bbf4a54c6b75900b5059835c382a0f (diff)
downloadxz-c97d12f300b2a94c9f54a44c8931c8bc08cf0a73.tar.gz
Doxygen: Refactor Doxyfile.in to doxygen/Doxyfile.
Instead of having Doxyfile.in configured by Autoconf, the Doxyfile can have the tags that need to be configured piped into the doxygen command through stdin with the overrides after Doxyfile's contents. Going forward, the documentation should be generated in two different modes: liblzma or internal. liblzma is useful for most users. It is the documentation for just the liblzma API header files. This is the default. internal is for people who want to understand how xz and liblzma work. It might be useful for people who want to contribute to the project.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 0 insertions, 40 deletions
diff --git a/configure.ac b/configure.ac
index ad94e01..631b187 100644
--- a/configure.ac
+++ b/configure.ac
@@ -520,45 +520,6 @@ AC_ARG_ENABLE([doc], [AS_HELP_STRING([--disable-doc],
AM_CONDITIONAL([COND_DOC], [test x$enable_doc != xno])
-###########
-# Doxygen #
-###########
-
-# Doxygen can be enabled in two different modes:
-# api - Only generate Doxygen html pages for liblzma API headers.
-# all - Generate Doxygen html pages for every file.
-# api mode is the default because the primary purpose for the doxygen
-# documentation is to publicaly describe liblzma's API. The other html
-# pages are only useful for those who want to understand or alter the
-# internals of xz and liblzma.
-
-AC_ARG_ENABLE([doxygen], [AS_HELP_STRING([--enable-doxygen=SCOPE],
- [Doxygen SCOPE can be `all', or `api'.
- The default is `api', which will generate doxygen html
- for liblzma API. The `all' option will generate doxygen
- html for every .c and .h file.])],
- [], [enable_doxygen=api])
-case $enable_doxygen in
- api)
- doxygen_project_name="liblzma ($PACKAGE_NAME)"
- doxygen_extract_private=NO
- doxygen_input_path=src/liblzma/api
- ;;
- all)
- doxygen_project_name="$PACKAGE_NAME"
- doxygen_extract_private=YES
- doxygen_input_path=src
- ;;
- *)
- AC_MSG_ERROR([--enable-doxygen only accepts `all' or `api'])
- ;;
-esac
-
-AC_SUBST([doxygen_project_name])
-AC_SUBST([doxygen_extract_private])
-AC_SUBST([doxygen_input_path])
-
-
##############
# Sandboxing #
##############
@@ -1171,7 +1132,6 @@ xz=`echo xz | sed "$program_transform_name"`
AC_SUBST([xz])
AC_CONFIG_FILES([
- Doxyfile
Makefile
po/Makefile.in
lib/Makefile