summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2015-08-11 13:23:04 +0300
committerLasse Collin <lasse.collin@tukaani.org>2015-08-11 13:23:04 +0300
commitcbc9e39bae715accb44168930a71888480aad569 (patch)
tree71b15633d8b804ead885156853606ae8f7a65c4b /configure.ac
parentbcacd8ce7a031566858e5e03c1009064c3f1c89e (diff)
downloadxz-cbc9e39bae715accb44168930a71888480aad569.tar.gz
Build: Minor Cygwin cleanup.
Some tests used "cygwin*" and some used "cygwin". I changed them all to use "cygwin". Shouldn't affect anything in practice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 74dcbf1..94e9007 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,8 +34,8 @@ AC_CANONICAL_HOST
# We do some special things on Windows (32-bit or 64-bit) builds.
case $host_os in
- mingw* | cygwin* | msys) is_w32=yes ;;
- *) is_w32=no ;;
+ mingw* | cygwin | msys) is_w32=yes ;;
+ *) is_w32=no ;;
esac
AM_CONDITIONAL([COND_W32], [test "$is_w32" = yes])
@@ -289,7 +289,7 @@ if test "x$enable_assembler" = xyes; then
case $host_os in
# Darwin should work too but only if not creating universal
# binaries. Solaris x86 could work too but I cannot test.
- linux* | *bsd* | mingw* | cygwin* | msys | *djgpp*)
+ linux* | *bsd* | mingw* | cygwin | msys | *djgpp*)
case $host_cpu in
i?86) enable_assembler=x86 ;;
x86_64) enable_assembler=x86_64 ;;