summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2022-10-31 16:26:05 +0200
committerLasse Collin <lasse.collin@tukaani.org>2022-10-31 16:26:05 +0200
commitcf118c014683069b5dbe91898acdc40f2f0a1f5d (patch)
treecd92f13d86354f6ff9a95522bb3a0f5af1574ce6 /configure.ac
parentaad3c609ffb72f581a7a2b67be3ad70b2b327840 (diff)
downloadxz-cf118c014683069b5dbe91898acdc40f2f0a1f5d.tar.gz
Build: Clarify comment in configure.ac about SSE2.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 11b25cd..20da4a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -820,7 +820,10 @@ if test "x$enable_external_sha256$sha256_func_found" = xyesno; then
AC_MSG_ERROR([--enable-external-sha256 was specified but no supported external SHA-256 implementation was found])
fi
-# Check for SSE2 intrinsics.
+# Check for SSE2 intrinsics. There is no run-time detection for SSE2 so if
+# compiler options enable SSE2 then SSE2 support is required by the binaries.
+# The compile-time check for SSE2 is done with #ifdefs because some compilers
+# (ICC, MSVC) allow SSE2 intrinsics even when SSE2 isn't enabled.
AC_CHECK_DECL([_mm_movemask_epi8],
[AC_DEFINE([HAVE__MM_MOVEMASK_EPI8], [1],
[Define to 1 if _mm_movemask_epi8 is available.])],