summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2010-10-08 15:25:45 +0300
committerLasse Collin <lasse.collin@tukaani.org>2010-10-08 15:25:45 +0300
commitb1c7368f95e93ccdefdd0748e04398c26766f47f (patch)
treefbba0f79912d7d009776a1b7e89b746677fbd8df /src/Makefile.am
parent630a8beda34af0ac153c8051b1bf01230558e422 (diff)
downloadxz-b1c7368f95e93ccdefdd0748e04398c26766f47f.tar.gz
Build: Add options to disable individual command line tools.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f03f5a3..9fb4caa 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,5 +5,18 @@
## You can do whatever you want with this file.
##
-SUBDIRS = liblzma xz xzdec lzmainfo scripts
+SUBDIRS = liblzma xzdec
+
+if COND_XZ
+SUBDIRS += xz
+endif
+
+if COND_LZMAINFO
+SUBDIRS += lzmainfo
+endif
+
+if COND_SCRIPTS
+SUBDIRS += scripts
+endif
+
EXTRA_DIST = common