summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLloyd Hilaiel <lloyd@hilaiel.com>2010-07-21 16:10:49 -0600
committerLloyd Hilaiel <lloyd@hilaiel.com>2010-07-21 16:11:19 -0600
commitd971f3af897d03ba93bf6f1c91c691ef52a6f1ff (patch)
tree1a8fed47495797cc6cf03dac230d4e102aaf3325 /CMakeLists.txt
parent221b6436b20b12aae6838814d38c6b17f5e32f7f (diff)
downloadyajl-d971f3af897d03ba93bf6f1c91c691ef52a6f1ff.tar.gz
gcc 3.4.6 compat, remove -Wno-missing-field-initializers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9692cc9..5fa3ec4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,7 +67,7 @@ IF (WIN32)
SET(CMAKE_C_FLAGS_RELEASE "/D NDEBUG /O2")
ELSE (WIN32)
SET(CMAKE_C_FLAGS
- "${CMAKE_C_FLAGS} -fPIC -std=c99 -pedantic -Wpointer-arith -Wno-format-y2k -Wstrict-prototypes -Wmissing-declarations -Wnested-externs -Wextra -Wundef -Wwrite-strings -Wold-style-definition -Wno-missing-field-initializers -Wredundant-decls -Wno-unused-parameter -Wno-sign-compare -Wmissing-prototypes")
+ "${CMAKE_C_FLAGS} -fPIC -std=c99 -pedantic -Wpointer-arith -Wno-format-y2k -Wstrict-prototypes -Wmissing-declarations -Wnested-externs -Wextra -Wundef -Wwrite-strings -Wold-style-definition -Wredundant-decls -Wno-unused-parameter -Wno-sign-compare -Wmissing-prototypes")
SET(CMAKE_C_FLAGS_DEBUG "-DDEBUG -g")
SET(CMAKE_C_FLAGS_RELEASE "-DNDEBUG -O2 -Wuninitialized")