summaryrefslogtreecommitdiff
path: root/reformatter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'reformatter/CMakeLists.txt')
-rw-r--r--reformatter/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/reformatter/CMakeLists.txt b/reformatter/CMakeLists.txt
index 6020d81..52a9bee 100644
--- a/reformatter/CMakeLists.txt
+++ b/reformatter/CMakeLists.txt
@@ -26,7 +26,13 @@ LINK_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
ADD_EXECUTABLE(json_reformat ${SRCS})
-TARGET_LINK_LIBRARIES(json_reformat m yajl_s)
+TARGET_LINK_LIBRARIES(json_reformat yajl_s)
+
+# In some environments, we must explicitly link libm (like qnx,
+# thanks @shahbag)
+IF (NOT WIN32)
+ TARGET_LINK_LIBRARIES(json_reformat m)
+ENDIF (NOT WIN32)
# copy the binary into the output directory
GET_TARGET_PROPERTY(binPath json_reformat LOCATION)