summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2004-09-07 07:39:26 +0000
committerPeter Johnson <peter@tortall.net>2004-09-07 07:39:26 +0000
commit72bce5ac1dad5ad558177b972159822b9952ca23 (patch)
tree5079de8c8112ab9c9edac00694445a046aac47e5 /Makefile.am
parent1a86c340266f98dbcb03cee8de382431d916fde9 (diff)
downloadyasm-72bce5ac1dad5ad558177b972159822b9952ca23.tar.gz
* configure.ac: Remove check for groff, add check for xmlto.
* Makefile: Add support for building man pages from DocBook XML refentry's using xmlto. * frontends/yasm/yasm.xml: New. Source XML file for yasm(1) man page. * frontends/yasm/yasm.1: Generated yasm(1) man page. We may want to remove this at some point, but it would have impact on those keeping up with HEAD. * frontends/yasm/Makefile.inc: Add new yasm(1) man page to distribution and install. * HACKING: Update required tools list. Rename "CVS" to "Subversion". Remove "Generating ChangeLogs" section, as with Subversion this is not necessary. svn path=/trunk/yasm/; revision=1138
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1204ff4d..5bd504c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,7 @@ AM_CPPFLAGS += -I$(top_srcdir)/check
AM_CPPFLAGS += @INCLTDL@
bin_PROGRAMS =
+man_MANS =
TESTS =
noinst_PROGRAMS =
@@ -82,3 +83,8 @@ ACLOCAL_AMFLAGS = -I m4
distclean-local:
-rm -rf results
+
+if BUILD_MAN
+.xml.1:
+ xmlto -o $(@D) man $<
+endif