summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2007-02-18 20:42:55 +0000
committerPeter Johnson <peter@tortall.net>2007-02-18 20:42:55 +0000
commit8aa68a2ee26af6f76551cb5be25bc5c9925abac2 (patch)
tree061bf3fdafe4b3cab70c18d7d4cbc9eb217acff4 /Makefile.am
parent7c5901713d041b71ce6cb6e8e6c093518521a71d (diff)
downloadyasm-8aa68a2ee26af6f76551cb5be25bc5c9925abac2.tar.gz
Fix build (hopefully) on Win64 by using uintptr_t more widely; Win64 is a
LLP64 platform so it's unsafe to cast pointers to unsigned long. Reported by: Chris Tophe <cohika@gmail.com> svn path=/trunk/yasm/; revision=1774
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 40c83381..21dbc393 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,7 @@ check_PROGRAMS = test_hd
test_hd_SOURCES = test_hd.c
include_HEADERS = libyasm.h
+include_HEADERS += libyasm-stdint.h
noinst_HEADERS = util.h
@@ -25,8 +26,8 @@ BUILT_SOURCES =
CLEANFILES = configure.lineno
EXTRA_DIST = config/config.rpath
-# _stdint.h doesn't clean up after itself?
-CONFIG_CLEAN_FILES = _stdint.h
+# libyasm-stdint.h doesn't clean up after itself?
+CONFIG_CLEAN_FILES = libyasm-stdint.h
# automake doesn't distribute mkinstalldirs?
EXTRA_DIST += config/mkinstalldirs
@@ -56,11 +57,11 @@ EXTRA_DIST += splint.sh
EXTRA_DIST += Mkfiles/Makefile.flat
EXTRA_DIST += Mkfiles/Makefile.dj
EXTRA_DIST += Mkfiles/dj/config.h
-EXTRA_DIST += Mkfiles/dj/_stdint.h
+EXTRA_DIST += Mkfiles/dj/libyasm-stdint.h
EXTRA_DIST += Mkfiles/vc/yasm.sln
EXTRA_DIST += Mkfiles/vc/yasm.vcproj
EXTRA_DIST += Mkfiles/vc/config.h
-EXTRA_DIST += Mkfiles/vc/_stdint.h
+EXTRA_DIST += Mkfiles/vc/libyasm-stdint.h
EXTRA_DIST += Mkfiles/vc/genmacro/genmacro.vcproj
EXTRA_DIST += Mkfiles/vc/genmacro/run.bat
EXTRA_DIST += Mkfiles/vc/genmodule/genmodule.vcproj
@@ -79,7 +80,7 @@ EXTRA_DIST += Mkfiles/vc8/crt_secure_no_deprecate.vsprops
EXTRA_DIST += Mkfiles/vc8/yasm.sln
EXTRA_DIST += Mkfiles/vc8/yasm.vcproj
EXTRA_DIST += Mkfiles/vc8/config.h
-EXTRA_DIST += Mkfiles/vc8/_stdint.h
+EXTRA_DIST += Mkfiles/vc8/libyasm-stdint.h
EXTRA_DIST += Mkfiles/vc8/readme.vc8.txt
EXTRA_DIST += Mkfiles/vc8/yasm.rules
EXTRA_DIST += Mkfiles/vc8/genmacro/genmacro.vcproj