summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2006-10-05 06:22:25 +0000
committerPeter Johnson <peter@tortall.net>2006-10-05 06:22:25 +0000
commit92f1ccd7d51fb49e778dbd904729645156f04434 (patch)
tree4f408c2a660bc423d05769b6963ba3c570ff08bf /Makefile.am
parent193a0c21d580fbbcca6612c2e7b5977cc909436c (diff)
downloadyasm-92f1ccd7d51fb49e778dbd904729645156f04434.tar.gz
Change genmodule to parse through the Makefile (or Makefile.am) looking for YASM_MODULES,
rather than simply taking a list of modules on the command line. This allows significant improvement of the behavior when used with Visual Studio, as the "old" way of doing this with Visual Studio build files was to scan through the .c files; this brought up things that were actually disabled in the build. Also incorporate a patch by Charles Bailey to make the VC8 build less noisy, and allow use of Win32 Bison if it's installed. Instructions updated as well. svn path=/trunk/yasm/; revision=1642
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a2d9322f..0bc3572e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,8 @@ EXTRA_DIST += Mkfiles/vc/re2c/re2c.vcproj
EXTRA_DIST += Mkfiles/vc/re2c/run.bat
EXTRA_DIST += Mkfiles/vc/gap/gap.vcproj
EXTRA_DIST += Mkfiles/vc/gap/run.bat
+EXTRA_DIST += Mkfiles/vc8/bison.rules
+EXTRA_DIST += Mkfiles/vc8/crt_secure_no_deprecate.vsprops
EXTRA_DIST += Mkfiles/vc8/yasm.sln
EXTRA_DIST += Mkfiles/vc8/yasm.vcproj
EXTRA_DIST += Mkfiles/vc8/config.h