summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2003-05-05 03:42:12 +0000
committerPeter Johnson <peter@tortall.net>2003-05-05 03:42:12 +0000
commitcfc6bf0dedf4aa501937be4406ed50e6e4649a97 (patch)
tree3c2cd30be56fc3c9edb4fa552e0b180e1a0ce35a /Makefile.am
parent959c7e1427108d4ebddf818bd6cdd149793cbc36 (diff)
downloadyasm-cfc6bf0dedf4aa501937be4406ed50e6e4649a97.tar.gz
Clean up and simplify libyasm.h options and symbol visibility:
- Move config.h and util.h from libyasm (and installed libyasm) to top level. - Move yasm_* functions from util.h to coretype.h. - Remove a number of autoconf-related YASM_*_INTERNAL options from libyasm.h. - Rename YASM_INTERNAL to YASM_LIB_INTERNAL; it now actually means what the comment describes: enables definitions that violate the yasm_* namespace. While we're at it, no longer define YASM_LIB_INTERNAL from yasm frontend, so it's closer to what a real typical libyasm-using application would look like. svn path=/trunk/yasm/; revision=944
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ae11a424..1719629b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-# $IdPath$
+# $IdPath: yasm/Makefile.am,v 1.48 2003/05/03 06:26:15 peter Exp $
SUBDIRS = libltdl m4 po .
@@ -15,6 +15,8 @@ noinst_PROGRAMS =
include_HEADERS = libyasm.h
+noinst_HEADERS = util.h
+
lib_LTLIBRARIES =
pkglib_LTLIBRARIES =