summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2007-09-10 06:59:47 +0000
committerPeter Johnson <peter@tortall.net>2007-09-10 06:59:47 +0000
commitf150e45913345aa753dc3307a0266043f199b25b (patch)
tree767b7fb098e9a8d972a908ad7caba296b945b4a5 /Makefile.am
parent502f5a1c4de42e4f53510159bc873b6b0fc1920a (diff)
downloadyasm-f150e45913345aa753dc3307a0266043f199b25b.tar.gz
Change x86 instruction tables to be automatically generated.
This combines the C and perfect hash tables into a single source file, and allows for easier future changes to the source-level structures. The Python-built files are included in the distribution so that Python is not added as a dependency. The generated code has been verified equal against the old tables, excepting a number of bugfixes. Most of the bugs fixed are in the CPU field, plus a few GAS suffix fixes. svn path=/trunk/yasm/; revision=1937
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d669d003..3eae0cb8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,9 @@ nodist_include_HEADERS = libyasm-stdint.h
noinst_HEADERS = util.h
BUILT_SOURCES =
+MAINTAINERCLEANFILES =
+DISTCLEANFILES =
+SUFFIXES =
# configure.lineno doesn't clean up after itself?
CLEANFILES = configure.lineno
@@ -77,8 +80,6 @@ EXTRA_DIST += Mkfiles/vc/re2c/re2c.vcproj
EXTRA_DIST += Mkfiles/vc/re2c/run.bat
EXTRA_DIST += Mkfiles/vc/genperf/genperf.vcproj
EXTRA_DIST += Mkfiles/vc/genperf/run.bat
-EXTRA_DIST += Mkfiles/vc/x86geninsn/x86geninsn.vcproj
-EXTRA_DIST += Mkfiles/vc/x86geninsn/run.bat
EXTRA_DIST += Mkfiles/vc8/crt_secure_no_deprecate.vsprops
EXTRA_DIST += Mkfiles/vc8/yasm.sln
EXTRA_DIST += Mkfiles/vc8/yasm.vcproj
@@ -100,11 +101,9 @@ EXTRA_DIST += Mkfiles/vc8/re2c/re2c.vcproj
EXTRA_DIST += Mkfiles/vc8/re2c/run.bat
EXTRA_DIST += Mkfiles/vc8/genperf/genperf.vcproj
EXTRA_DIST += Mkfiles/vc8/genperf/run.bat
-EXTRA_DIST += Mkfiles/vc8/x86geninsn/x86geninsn.vcproj
-EXTRA_DIST += Mkfiles/vc8/x86geninsn/run.bat
# Until this gets fixed in automake
-DISTCLEANFILES = libyasm/stamp-h libyasm/stamp-h[0-9]*
+DISTCLEANFILES += libyasm/stamp-h libyasm/stamp-h[0-9]*
ACLOCAL_AMFLAGS = -I m4
@@ -119,7 +118,7 @@ install-exec-hook: python-install
uninstall-hook: python-uninstall
if BUILD_MAN
-MAINTAINERCLEANFILES = $(dist_man_MANS)
+MAINTAINERCLEANFILES += $(dist_man_MANS)
endif
# genstring build