summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2004-09-10 22:58:04 +0000
committerPeter Johnson <peter@tortall.net>2004-09-10 22:58:04 +0000
commitf916f1c79d044adf625031a99d65b85b269f5fec (patch)
tree1eb1cae20a304087845525f7196112869c4fcac1 /Makefile.am
parent83ad81cf4f8c8074465081fecff5c34410d43442 (diff)
downloadyasm-f916f1c79d044adf625031a99d65b85b269f5fec.tar.gz
* arch/lc3b/README, arch/x86/README: Remove (replaced by man page).
* yasm_arch.xml, yasm_arch.7: Add new man page describing architectures. * yasm.xml, yasm.1: Reference yasm_arch(7). * Makefile.am: Add build rules for .7 man pages. * modules/arch/Makefile.inc: Build yasm_arch.7. svn path=/trunk/yasm/; revision=1140
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 31b36db2..5b432245 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,10 +87,15 @@ distclean-local:
if BUILD_MAN
.xml.1:
$(XMLTO) -o $(@D) man $<
+.xml.7:
+ $(XMLTO) -o $(@D) man $<
else
.xml.1:
@echo "Not rebuilding man page from $<"
cp `test -f $*.1 || echo '$(srcdir)/'`$*.1 $@
+.xml.7:
+ @echo "Not rebuilding man page from $<"
+ cp `test -f $*.7 || echo '$(srcdir)/'`$*.7 $@
endif
BUILT_SOURCES += $(man_MANS)