summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2006-12-30 03:19:24 +0000
committerPeter Johnson <peter@tortall.net>2006-12-30 03:19:24 +0000
commita8ef216fc052f8b8cfd02d6db88be42bcf9d5465 (patch)
tree223bfd7aad42fff210653dd4d850a04e0b970631 /configure.ac
parentb188db0311e97cff57521d6219ee4bdcd3589a22 (diff)
downloadyasm-a8ef216fc052f8b8cfd02d6db88be42bcf9d5465.tar.gz
GAS parser: convert to recursive descent.
Remove all Bison supporting struts as we no longer need Bison. svn path=/trunk/yasm/; revision=1724
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index e15066fc..45ae2b17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,28 +64,6 @@ esac], enable_python="auto")
#
# Checks for programs.
#
-AC_PROG_YACC
-# check for Bison in particular
-if test "$YACC" != "bison -y"; then
- AC_MSG_WARN([You will need GNU Bison if you want to regenerate parsers.])
- YACC=
-else
- AC_MSG_CHECKING([bison version])
- set `bison --version | grep 'GNU Bison' | sed -e 's/^@<:@A-Za-z() @:>@*//g' -e 's/\./ /'`
- if test -z "$1" -o -z "$2"; then
- AC_MSG_RESULT([unknown])
- AC_MSG_WARN([You will need GNU Bison 1.25 or better if you want to regenerate parsers.])
- YACC=
- else
- if test "$1" = "1" -a "$2" -lt "25"; then
- AC_MSG_RESULT([$1.$2])
- AC_MSG_WARN([You will need GNU Bison 1.25 or better if you want to regenerate parsers (found $1.$2).])
- YACC=
- else
- AC_MSG_RESULT([$1.$2 (ok)])
- fi
- fi
-fi
AC_PROG_CC_STDC
AC_PROG_INSTALL
AC_PROG_LN_S