summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Johnson <peter@tortall.net>2010-01-01 20:55:07 +0000
committerPeter Johnson <peter@tortall.net>2010-01-01 20:55:07 +0000
commitfcb228f18cd5c1286e79ff3d0e7b6a299df76fc6 (patch)
treea8eb6cbea4eed2c57ccaefea85e7772a722115ae /configure.ac
parentf608f67ad258a7802a674809f2e5472c7651aef9 (diff)
downloadyasm-fcb228f18cd5c1286e79ff3d0e7b6a299df76fc6.tar.gz
Use Cython instead of Pyrex.
svn path=/trunk/yasm/; revision=2256
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 40d99510..7883dc47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,31 +280,31 @@ else
fi
# Detect if we can build Python bindings
-# (needs Python, Python headers, and Pyrex)
+# (needs Python, Python headers, and Cython)
if test x$enable_python_bindings = xno; then
have_python_bindings=no
else
AC_MSG_NOTICE([Checking to see if we can build Python bindings])
have_python_bindings=no
if test x$have_python = xyes; then
- AC_MSG_CHECKING([for Pyrex >= 0.9.5.1])
- PYREX_CHECK_VERSION(0.9.5.1, [AC_MSG_RESULT(yes)
- have_pyrex=yes],
+ AC_MSG_CHECKING([for Cython >= 0.11.3])
+ CYTHON_CHECK_VERSION(0.11.3, [AC_MSG_RESULT(yes)
+ have_cython=yes],
[AC_MSG_RESULT(no)
- have_pyrex=no])
+ have_cython=no])
AM_CHECK_PYTHON_HEADERS(have_python_headers=yes,have_python_headers=no)
- if test x$have_pyrex = xyes -a x$have_python_headers = xyes ; then
+ if test x$have_cython = xyes -a x$have_python_headers = xyes ; then
have_python_bindings=yes
fi
fi
if test x$have_python_bindings = xno ; then
if test x$enable_python_bindings = xyes ; then
- AC_MSG_ERROR([Building Python bindings explicitly requested, but can't build Python bindings because either Pyrex, Python headers or a suitable Python version was not found])
+ AC_MSG_ERROR([Building Python bindings explicitly requested, but can't build Python bindings because either Cython, Python headers or a suitable Python version was not found])
else
- AC_MSG_WARN([Couldn't find either Pyrex, the Python headers or a suitable version of Python, not building Python bindings])
+ AC_MSG_WARN([Couldn't find either Cython, the Python headers or a suitable version of Python, not building Python bindings])
fi
fi
fi