summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManish Sinha <manishsinha@ubuntu.com>2013-03-09 15:16:01 -0700
committerManish Sinha <manishsinha@ubuntu.com>2013-03-09 15:16:01 -0700
commitfeaf96a89db3b2ccfaa650e7aa08993c5b164e9e (patch)
tree5139cb0539274c93b9074d0f9989ff71fedcffba /configure.ac
parentb693ba91936212d6d64a0450e79aa944549e76fa (diff)
downloadzeitgeist-feaf96a89db3b2ccfaa650e7aa08993c5b164e9e.tar.gz
Makes sure that gtkdoc-scan is also checked during configure
This fixes the bug when gtk-doc-tools was not installed, hence gtkdoc-scan was not available. gtk doc generation is enabled by default and checks for only valadoc, but it ends up using gtkdoc-scan too somewhere in the codebase (probably for extracting docs from header files)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d8144d1..2da28821 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,9 +183,16 @@ AS_IF([test "x$enable_docs" != "xno"], [
], [
AS_IF([test "x$enable_docs" == "xyes"], AC_MSG_ERROR([Unable to find valadoc]))
])
+ AC_PATH_PROG(GTKDOC_SCAN, gtkdoc-scan, :)
+ AS_IF([test -x "$GTKDOC_SCAN"], [
+ found_gtkdoc_scan=yes
+ AC_SUBST(GTKDOC_SCAN)
+ ], [
+ AS_IF([test "x$enable_docs" == "xyes"], AC_MSG_ERROR([Unable to find gtkdoc-scan]))
+ ])
])
-AM_CONDITIONAL(ENABLE_DOCS, test "x$found_valadoc" = "xyes")
+AM_CONDITIONAL(ENABLE_DOCS, test "x$found_valadoc" = "xyes" -a "x$found_gtkdoc_scan" = "xyes")
AM_CONDITIONAL([HAVE_INTROSPECTION], [test "x$enable_vala" = "xyes"])