summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 8 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 97d0284..222d264 100644
--- a/meson.build
+++ b/meson.build
@@ -65,15 +65,14 @@ opt_missing_str = '''
Requested optional @0@ support but library not found.
Please ensure you have any required development libraries installed.'''
-# TODO
-#webkitgtk = dependency('webkit2gtk-4.0', version: '>= 2.8.1', required: false)
-#if get_option('webkitgtk')
-# if webkitgtk.found()
-# zenity_conf.set('HAVE_WEBKITGTK', true)
-# else
-# error(opt_missing_str.format('webkitgtk'))
-# endif
-#endif
+webkitgtk_dep = dependency('webkit2gtk-5.0', required: false)
+if get_option('webkitgtk')
+ if webkitgtk_dep.found()
+ zenity_conf.set('HAVE_WEBKITGTK', true)
+ else
+ error(opt_missing_str.format('webkitgtk'))
+ endif
+endif
configure_file(
output: 'config.h',