summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGraham Leggett <minfrin@apache.org>2020-03-10 21:31:58 +0000
committerGraham Leggett <minfrin@apache.org>2020-03-10 21:31:58 +0000
commitd484a5ba10d4ea4e623b3e3969d3fdf54791e7e6 (patch)
tree1924cdfaff263cc32f9f25ef6ec81c93ca5a6b2d /configure.in
parent7e7899c6834b83f4b147daaadfdbd4fb5531507d (diff)
downloadapr-d484a5ba10d4ea4e623b3e3969d3fdf54791e7e6.tar.gz
Add a cache check with which users who cross-compile APR
can influence the outcome of the /dev/zero test by setting the variable ac_cv_mmap__dev_zero=yes git-svn-id: https://svn.apache.org/repos/asf/apr/apr/trunk@1875062 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 2d44cafd5..47f0d0b26 100644
--- a/configure.in
+++ b/configure.in
@@ -1092,10 +1092,10 @@ AC_CHECK_FILE(/dev/zero)
# Not all systems can mmap /dev/zero (such as HP-UX). Check for that.
if test "$ac_cv_func_mmap" = "yes" &&
- test "$ac_cv_file__dev_zero" = "yes"; then
- AC_MSG_CHECKING(for mmap that can map /dev/zero)
- AC_TRY_RUN([
-#include <sys/types.h>
+ test "$ac_cv_file__dev_zero" = "yes"; then
+ AC_CACHE_CHECK([for mmap that can map /dev/zero],
+ [ac_cv_mmap__dev_zero],
+ [AC_TRY_RUN([#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>
#ifdef HAVE_SYS_MMAN_H
@@ -1117,9 +1117,7 @@ if test "$ac_cv_func_mmap" = "yes" &&
return 3;
}
return 0;
- }], [], [ac_cv_file__dev_zero=no], [ac_cv_file__dev_zero=no])
-
- AC_MSG_RESULT($ac_cv_file__dev_zero)
+ }], [], [ac_cv_file__dev_zero=no], [ac_cv_file__dev_zero=no])])
fi
# Now we determine which one is our anonymous shmem preference.