summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Orton <jorton@apache.org>2018-06-07 13:17:27 +0000
committerJoe Orton <jorton@apache.org>2018-06-07 13:17:27 +0000
commitc2f9d44ea901541debb734be88f0d9f3621f3df9 (patch)
tree109b218bd5eb32845b234395e667b7b56fb21186 /configure.in
parent7711d39400b6b2a8d210fb85b32bad59cf2a9d49 (diff)
downloadhttpd-c2f9d44ea901541debb734be88f0d9f3621f3df9.tar.gz
* configure.in, Makefile.in: Handle no-test-suite case through
check-no rule. Only regenerate the test suite on repeated "make check" run if a header file has changed. git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1833122 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4315aa1cc4..0eac9e0d6e 100644
--- a/configure.in
+++ b/configure.in
@@ -923,12 +923,14 @@ AC_ARG_WITH([test-suite],
else
test -f "$withval/Makefile.PL" || AC_MSG_ERROR([--with-test-suite directory $withval does not contain the expected Makefile.PL])
TEST_SUITE_LOCATION="$withval"
+ WITH_TEST_SUITE=yes
fi
],
- [ TEST_SUITE_LOCATION="no" ]
+ [ WITH_TEST_SUITE=no ]
)
APACHE_SUBST(TEST_SUITE_LOCATION)
+APACHE_SUBST(WITH_TEST_SUITE)
APACHE_FAST_OUTPUT(Makefile modules/Makefile srclib/Makefile)
APACHE_FAST_OUTPUT(os/Makefile server/Makefile)