summaryrefslogtreecommitdiff
path: root/client/meson.build
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2022-06-07 09:43:17 +0100
committerRichard Hughes <richard@hughsie.com>2022-06-08 08:05:43 +0100
commitb6cb98ee0f1fefc5831d9e3b63b727414a750567 (patch)
tree023070279c877678a93217081ea00b859a882269 /client/meson.build
parentc6c37d096f3d236e86c3073a58f7836298b05faa (diff)
downloadappstream-glib-b6cb98ee0f1fefc5831d9e3b63b727414a750567.tar.gz
Port from libsoup to libcurl
The former bumped ABI, and all sorts of crazy happens when you link in libappstream-glib into a process with the 'other' ABI. It seems the universe has settled on curl as a dep; do the same.
Diffstat (limited to 'client/meson.build')
-rw-r--r--client/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/client/meson.build b/client/meson.build
index d520508..fd03e62 100644
--- a/client/meson.build
+++ b/client/meson.build
@@ -10,9 +10,9 @@ if get_option('builder')
asbuilder_incdir,
],
dependencies : [
- glib,
+ gio,
gdkpixbuf,
- soup,
+ libcurl,
libarchive
],
link_with : [
@@ -33,9 +33,9 @@ appstream_util = executable(
asglib_incdir,
],
dependencies : [
- glib,
+ gio,
gdkpixbuf,
- soup,
+ libcurl,
libarchive,
],
link_with : asglib,
@@ -52,9 +52,9 @@ appstream_compose = executable(
asglib_incdir,
],
dependencies : [
- glib,
+ gio,
gdkpixbuf,
- soup,
+ libcurl,
libarchive,
],
link_with : asglib,